·
Resolved
The issues affecting PSQ Impact System have been resolved. All systems are now operating normally.
Investigating
We're aware of issues affecting PSQ Impact System and are investigating.
Updates to follow shortly.